Skip to content

Um Pouco de Excel – P2: O PROCV

Procv. Esta função, que para muita gente parece uma mistura de bicho-de-sete-cabeças com Oráculo (não confundir com Oracle), no fundo é bastante simples, e pode facilitar bastante nosso trabalho.

Há quase 2 anos atrás, criei um post sobre Excel, e a ideia seria continuar escrevendo regularmente algumas dicas de quem passa horas e horas trabalhando neste programa de linhas e colunas. O fato é que nesse tempo, tempo é o que mais vem faltando, e por isso demorei tanto a falar no assunto.

Chega de conversa. Vamos trabalhar um pouco. Nosso objetivo hoje será criar uma planilha em que digitamos uma data em uma célula qualquer e ela nos retorna o valor do Dólar Comercial para aquela data. Vou tentar ser o mais detalhado possível.

Para começar, crie uma nova pasta de trabalho no Excel. Em seguida, vamos digitar as informações da cotação do dólar, começando pela célula B2, com as datas uma abaixo da outra na coluna B e as cotações ao lado da respectiva data, na coluna C:

Cotacao dolar

Aqui começa a primeira regra a ser seguida quando se vai utilizar o PROCV: os valores em que vamos procurar o que queremos devem sempre estar à esquerda dos valores que queremos retornar. SEMPRE!

Depois disso, vamos pintar a célula E2 de amarelo, apenas para destacá-la. É nela que vamos colocar a data que queremos retornar a cotação. Feito isso, vamos começar a escrever a fórmula, ma célula F2, que é onde será retornada a cotação do dólar para o dia que escrevermos na célula E2.

O PROCV é dividido em 4 partes: o que procuramos, onde procuramos, que valor retornar, e a precisão. No nosso caso, a precisão vai ser exata, ou seja, a fórmula só nos retorna resultado se exatamente o que procuramos for encontrado.

Com a célula F2 selecionada, digite:

=procv(E2;$B$2:$C:$8;2;0)

Explicando: o “=procv(” indica a função que vamos utilizar é a PROCV. os parâmetros da função, separados por ; são, respectivamente:

  • E2 – a célula que contém o valor que vamos procurar. O VALOR que está dentro da célula. Se nela há uma fórmula que retorna um valor, o que vai ser procurado vai ser este VALOR.
  • $B$2:$C$8 –  onde está a tabela com os dados. Aqui está o pulo do gato do PROCV, pois a fórmula só procura valores na primeira coluna. Então, se o valor que você procura está na segunda coluna, você não vai conseguir encontrá-lo com um PROCV simples. Outro detalhe SUPER importante é bloquear o intervalo para não se mover com as linhas ou colunas caso a fórmula seja arrastada. Se o valor que você procurar estiver em uma posição na lista menor que o número de células arrastadas para baixo, ele não será encontrado. Se arrastar para o lado, a primeira coluna deixará de ser a que contêm o valor que se procura. Então, SEMPRE bloqueie as células do intervalo.
  • 2 – Número da coluna do intervalo da qual queremos retornar o valor. Aqui entra a mecânica do PROCV: dizemos um valor, ele procura na primeira coluna de uma tabela, e quando encontra, retorna a coluna que pedimos na mesma linha.
  • 0 – Correspondência exata: só retorna o valor caso se encontre EXATAMENTE o que procuramos. Se tiver um espaço a mais, já era.

Dê enter.

Nossa planilha deve ficar assim:

Procv

O valor retornado é um erro, mas porque estamos procurando “vazio”, que é o resultado que temos na célula amarela (E2). Agora, digite uma data da tabela na célula amarela, e veja o resultado:

Procv2

Na célula F2, o resultado da fórmula foi o a cotação do dólar no dia escolhido. Tente mudar a data e veja o resultado. Coloque uma data que não está na tabela, e vamos ter o mesmo erro que tivemos com a célula amarela “vazia”. Isso é porque o PROCV retorna um erro quando ele não encontra o valor que pedimos na primeira coluna da tabela. Há algumas formas de tornar este erro mais apresentável, mas sobre isso falarei em um outro post.

É isso, pessoal! Muito complicado? Com um pouco de prática, os PROCV’s começam a ser mentais, fácil, fácil.

Espero ter ajudado! Se quiser, pode fazer o download do arquivo que preparamos aqui: procv.xls.

4 Comments

  1. EDINEI SANTOS EDINEI SANTOS

    fiz uma tabela para futebol no excel, mas antes de inserir o resultado o sistema marca 1 ponto, está reconhecendo como empara. Não encontrei o erro.
    =SE(C1>E1;3)+SE(C1<E1;0)+SE(C1=E1;1)
    Não consegui colocar na formula (se vazio = sero).

    outro problema que estou encontrando é que quando 2 times empatam em todos os critérios, na tabela de classificação repete o time
    =MAIOR(R$2:R$5;H2) – Onde R2:R5 são os resultados da formula e H2 é o primeiro da lista.
    se puder me ajudar agradeço.
    Edinei Santos
    edineidess1969@gmail.com

    • Edinei, na primeira fórmula eu faria assim:

      =SE(C1>E1;3;SE(C1=E1;1;0))

      Na tabela de Classificação, se dois times empatam em todos os critérios que você tem listado é preciso criar um critério novo, nem que seja ordem alfabética. Caso contrário, o Excel não conseguirá decidir nada.

      Abs!

  2. Renato Silva Renato Silva

    Bom dia Vitor Franco, estou querendo fazer procv puxando uma planilha a outra mas estou com dificuldades,=procv(coluna codigo;seleciono na outra planilha as colunas que preciso;ponho numero de colunas ;0) e não da certo, pois aula que me deste foi super importante e de grande valia, mas pode me dar uma ajuda nesta planilha que pretendo fazer.

    Renato

  3. Yuri Eusébio Yuri Eusébio

    Bom dia gostaria mesmo de saber como criar uma tabela de classificação automática de futebol, onde entra derrotas, empates, vitórias, golos marcados e sofridos e pontos acumulados.

Deixe uma resposta